DatStat Connect™ Hardware & Software Requirements

This guide describes the minimum system requirements for running DatStat Connect™ software.

1.Server Requirements

Hardware

DatStat recommends the following dedicated hardware resources at a minimum

Web Server

  • Processor : Quad Core Server Class Processor 2.2 GHz +
  • RAM : 8 GB Server Memory
  • Storage :
    • Installation Location requires 200 MB
    • Logs require a minimum of 500 GB Hard Drive Space based on archiving and storage requirements/policies

Database Server

  • Processor : Quad Core Server Class Processor 2.2 GHz + – More CPU Power may be required depending on how busy the database server is
  • RAM : 8 GB Server Memory – More memory may be required depending on how busy this database server is
  • Storage : The DatStat database can be as small as 5 GB or as large as 100 GB – This is dependent on Survey revisions, number of campaigns, respondent data, audit data, and other data stored by the product

Software

DatStat recommends the following dedicated software resources

Web Server

  • Windows Server 2012 or better
  • IIS 8 or better
  • .NET Core 1.1

Database Server

  • MongoDB 3.4 or better
  • Latest security patches and updates
Was this helpful? Yes No Suggest edit

2.Client Requirements

Hardware

DatStat recommends the following dedicated hardware resources at a minimum

  • Processor : Intel Core i5 2.0 GHz or Better
  • RAM : 8 GB Memory
  • Storage : 50 MB Installation + Storage of exported activities

Software

DatStat recommends the following dedicated software resources

  • Windows 7 or better
  • .NET Frameworks
    • 2.0
    • 3.5
    • 4.0
    • 4.5
    • 4.5.1
  • Latest security patches and updates
Was this helpful? Yes No Suggest edit

3.Browser Support

The following list of web browsers are support by DatStat in use of the DatStat Connect™ Platform. When using the product in one of these browsers the user can expect full access to the product’s features. If using a browser or browser version not mentioned below the user may experience difficulties interacting with the product’s interface and functionality.

JavaScript is required to be enabled on any browser that is used to access the platform’s web interface.

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge
  • Internet Explorer 10 or higher
  • Safari
Was this helpful? Yes No Suggest edit
Suggest Edit